1

Topic: Wolf CMS doesn't write database contents

I recently designed a website for a client using Wolf cms, after I finished developing the site on my local server it was time to install Wolf CMS 7.8 on the server where the website is supposed to be hosted but the installation just won't work.

(before I go into the details the "symptoms" of the problems I have are pretty similar to the ones described in this topic: http://www.wolfcms.org/forum/topic1193.html, (this user even uses the same hosting service) however since no solution was stated and the topic is really old I figured it would be better to open a new one)

When the installation checks the requirement there doesn't appear anything out of the ordinary:

Requirement     Available?
PHP 5.1.2     PHP 5.3.28
PDO supported     true
PDO supports MySQL 1)     true
PDO supports SQLite 3 1)     true
PDO supports PostgreSQL 1)     false
Config file exists 2)     true
Config file is writable 2)     true
Public directory is writable 3)     true
Clean URLs support available 4)     not detected (Right now I don't actually care about clean URLs, I just want it to work...)

... so I click on continue install and input all my database Informations (MySQL, the server is rdbms.strato.de as with all domains registered on strato, the User and database name generated by strato and the password I defined for it, I leave the port on 3306)
I leave the admin account name as it is and clear the URL suffix box,not sure if that matters for the solution but I'm telling you to make sure.
I click the install button and I simply get a blank page, not totally blank, I still have the brown bar saying "Wolf CMS" but the white box that should show installation infromation is just completely empty. According to my browswer the page keeps transferring information for a few minutes. Nothing happens after that. Refreshing results in a page asking me if I want to upgrade to Wolf CMS 7.8 even though 7.8 is the version I have installed.
Trying to access the main page of the website by deleting the "wolf/install/index.php" path from the address will show a completely blank page that loads for a while before showing an "Internal Server Error" message (trying that before removing the permissions from the config.php file still gives the normal security warning).

At this point I Inspected the files on the server: The config.php has been filled with information, nothing looks wrong to me, the access data for the MySQL database are all transferred correctly. 

then I check the contents of the MySQL database via PHPmyAdmin ...and see that it is still completely empty. For some reason the installation has added no new information whatsoever.
I tried this installation a couple of times already. I delete the wolf CMS files from my server and copy the fresh files directly from the 7.8 zip.
I also clear the database (doesn't do anything because it's empty, but I do it, again, just to be sure) and have even deleted it and created a new one, always with the same result.

I also tested some other things and found something curious:
Filling something wrong into the database server field gives an MySQL error as expected, so does typing in a wrong database  or user name, but as long as the server, database name and user name are correct it doesn't matter what password is used. I get an access denied error if I leave out the password entirely, but as long as anything is entered in the password field, the installation will "continue" just as if I entered the correct password, it doesn't give me any error if i try to get in with a wrong password.
I don't know what this means for the communication with the database. Aparrently the installation manages to check if the databse and the User exist and if the user has a password, but then the communication screws up before it can even verify if the password can access the database.

I'm pretty confused by this, can anyone help?

Thumbs up

2

Re: Wolf CMS doesn't write database contents

Wow, this is a long one tongue

Well, first of all, since you have your site on localhost (your PC), there is no need to install Wolf onto your live host!

You just need to move it, set db and it should work. I did it bunch of times.

Here are the steps:

1. .zip your local finished site (this includes: /wolf, /public, index.php, config.php, .htaccess)
2. Via phpmyadmin export your database somewhere on your PC (you should get "something.sql file)
3. Upload and unpack .zip (from point 1.) in the root of your web folder (should be called /public_html)
4. Create database on via your hosting account (remember username, pass and db name)
5. Navigate to your db via phpmyadmin
5.1 Select database (in left sidebar)
5.2 Go to import, then Browse, then Select your "something.sql" from your PC and click "Go" button (or Import, I can't remember exactly)
5.3 Check the imported tables to see if there is data in them
6. Open config.php file and update info about user, db name and password (the rest should be ok)
6.1 On line 28 correct domain name:

define('URL_PUBLIC', 'http://YOUR-DOMAIN-HERE/');

if this does not work, add "WWW" in front of url

NOTE:  if config file is not writable, change permissions to 777 and revert them to 644 or 444 after you done editing

6.2 If you want "clean" url's then leave "USE_MOD_REWRITE" to true and correct .htaccess file to point RewriteBase to / only!!!

7. Check out your site.

This should roughly be it and it should work right away.
Try it and let me know how that went.

Tutorials at Project 79 | Wolf CMS Docs

3

Re: Wolf CMS doesn't write database contents

Hi all! I tried to install a new instance of Wolf and got the same issue as TMKH. More times. I tried a 0.7.8 version too and got the same....

Any ideas?

Thumbs up