Topic: Asset manager

There is a working branch of Assets plugin for Wolf. Get it from GitHub or as tarball.

If you use GitHub make sure you checkout Wolf branch after doing a git clone.

Thumbs up

Re: Asset manager

That's what I've really missed from Frog.
Unfortunatelly, it keeps telling me that my system does not have JPEG support (which is not true). It lets me upload even jpg, but don't create any thumbnail... (I have Image Resize, jQuery & jQuery UI instaled, Page not found plugin was enabled as the last one)... sad

Thanks for any help wink

EDIT: I've changed the attributes of the folder to 775 and it creates thumbs now! smile But still can't get rid of the "no JPEG support" message hmm

Last edited by ivy046 (2010-02-27 19:56)

3

Re: Asset manager

I'm getting the red flash of non-jpeg compliance also...

Thumbs up

Re: Asset manager

Tony: Which PHP version do you have? There seems to be differences on how JPEG support is reported.

Thumbs up

Re: Asset manager

I have 5.2.10 version.

6

Re: Asset manager

I have stuck a info.phpfile on the server for a better view of what might be causing issues.

actually i don't know if that is a wise thing to do so here's the php version

PHP Version 5.2.10

Last edited by Tony (2010-03-09 13:51)

Thumbs up

Re: Asset manager

I just ran thru the same issues. The jpeg support problem is fixed on my system by changing line 349 in wolf/plugins/assets/AssetsController.php to:

    $needed   = array('GIF Read Support', 'JPG Support', 'PNG Support');

Notice that it says 'JPG' not 'JPEG'. This is how gd_info() reports its support on my system. I don't know if this is different on other systems or versions of gd or what.

Hope that helps.

Thumbs up

Re: Asset manager

Has anyone made this work in wolf 0.6.0?
The assets manager doesn't install

Thumbs up

9

Re: Asset manager

wemago wrote:

Has anyone made this work in wolf 0.6.0?
The assets manager doesn't install

Yes, it's working nicely for me. Heather had some issues getting it working, but reported her solutions on the forum. Does that help?

Using Wolf CMS professionally and for profit? Do think about supporting Wolf financially. Thanks!

10

Re: Asset manager

David wrote:
wemago wrote:

Has anyone made this work in wolf 0.6.0?
The assets manager doesn't install

Yes, it's working nicely for me. Heather had some issues getting it working, but reported her solutions on the forum. Does that help?

Nop nothing, even with a fresh install or with wolf gits version, i've downloaded assets from
gits, so it already has those solutions from heather, the only thing needed is to modify index.php
to remove frogs version needed and modify FROG_ROOT to CMS_ROOT, but still cant get anything.

Edit: when installed in fresh install of wolf 0.6.0a breaks the plugins page.

Last edited by wemago (2010-05-21 11:00)

Thumbs up

11

Re: Asset manager

wemago wrote:

Nop nothing, even with a fresh install or with wolf gits version, ... still cant get anything.

Edit: when installed in fresh install of wolf 0.6.0a breaks the plugins page.

Can you tell use more about your environment? Versions of PHP? db? etc?

Using Wolf CMS professionally and for profit? Do think about supporting Wolf financially. Thanks!

12

Re: Asset manager

David wrote:
wemago wrote:

Nop nothing, even with a fresh install or with wolf gits version, ... still cant get anything.

Edit: when installed in fresh install of wolf 0.6.0a breaks the plugins page.

Can you tell use more about your environment? Versions of PHP? db? etc?

PHP 5.3.0
mysql 5.1.37

Thumbs up

13

Re: Asset manager

How many assets can be on the sidebar when editing a page? I'm getting only eight images, although i've uploaded more. All pictures are displayed in assets backend.

Thumbs up

14

Re: Asset manager

xkapr wrote:

How many assets can be on the sidebar when editing a page? I'm getting only eight images, although i've uploaded more. All pictures are displayed in assets backend.

I believe that is a built-in limitation of this plugin (bug? or feature!). That is, the expectation is that only the most recently uploaded "assets" are required for placement on webpages, so only the most recent 8 assets are shown.

I'm not sure of a work-around for this, and it's not my plugin, but perhaps that observation helps to manage expectations.

Using Wolf CMS professionally and for profit? Do think about supporting Wolf financially. Thanks!

Re: Asset manager

Ok. I am back. Just made a quick fix for asset manager to work with Wolf 0.6.0. I made only short testing but technically everything seems to be ok atleast with my install. There still are some CSS issues but I remember seeing fix somewhere here in the forums.

Note that you do not need my jQuery and jQuery UI plugins anymore. Wolf has them now by default.

You can follow development here:
http://github.com/tuupola/wolf_assets

And download latest  (0.5.0-dev at the time of writing) from:
http://www.appelsiini.net/download/wolf_assets.tar.gz

I would appreciate if  other could try it too. David I am looking at you smile Will do some more testing tonight (if Starcraft II allows me to). Patches are always welcome. Just fork and send pull request.

For bugreports I prefer GitHub (if you do not have account this forums is fully ok too):
http://github.com/tuupola/wolf_assets/issues

I will be converting all my Frog stuff to Wolf in next couple of weeks. Funky Cache and Dashboard are first on the list.

Thumbs up

16

Re: Asset manager

tuupola wrote:

I would appreciate if  other could try it too. David I am looking at you smile

Huh?! Wha...?! Me? wink

Actually, tried it on a site ... logged a couple issues. Is this for 0.6.0a ("strict"!) at the moment?

Update - I'll add things on the git issue-tracker (it is a nice system!); but for the record, it is both an SVN version (I think 201), but now also duplicated with a fresh install of 0.6.0a. hmm

Last edited by David (2010-08-25 13:39)

Using Wolf CMS professionally and for profit? Do think about supporting Wolf financially. Thanks!

Re: Asset manager

Yeah testing for 0.6.0a only at the moment. Will check trunk later (although I am not big fan of working with svn, git is bliss .:)

The errors you reported are with svn version?

Thumbs up

Re: Asset manager

Made new development release (0.5.0-dev3) which fixes some CSS issues. Especially with TinyMCE plugin.

Download from:
http://www.appelsiini.net/download/wolf_assets.tar.gz

Check code changes at:
http://github.com/tuupola/wolf_assets/commits/master

Thumbs up

19

Re: Asset manager

Can someone confirm whether or not there is still a limit on the number of images in the sitebar. I have no difficulty doing 10, but I am worried I will hit a limit somewhere unexpectedly later.

Thumbs up

20

Re: Asset manager

Hi Graeme - this isn't a cast-iron guarantee, but I'm quite sure that as you add new items, old ones will drop off. That is, you get the "n" latest "assets", whatever number "n" is meant to be! You shouldn't run into difficulties as you continue to add things.

Using Wolf CMS professionally and for profit? Do think about supporting Wolf financially. Thanks!

21

Re: Asset manager

Thanks David, that is still potentially a problem but "n" seems to be higher for me than the eight reported  earlier.

Thumbs up

Re: Asset manager

I have wolfCMS installed in a sub directory and assets doesn‘t seam to be able to locate it‘s images right. Do I have to setup something spacial to make it work or is this a bug?

Thumbs up

23

Re: Asset manager

Hi,

I follow all the steps to install this plugin. After enabled it the Asset tab dont appear (has as supposed to be).  When I'm creating a new page the side bar dont appear neither.

Can someone help me?

Thanks!

Thumbs up

24

Re: Asset manager

Hm, I haven't tried this plugin since it was first released, but have you renamed your plugin folder to "assets"? Can you confirm that? Other then that, this plugin should be revised and updated.

My Wolf CMS related blog Project 79 | Wolf CMS Docs

25

Re: Asset manager

Hi Jackie,

Thanks for helping me. Yes, I already do that.

Now I disable and then re-enable it the Page not found plugin again and then appear the Assets tab but dont work so fine. When I'm inside the Assets tab it looks a bit strange.. Dont show the page icon (on the sidebar near the settings link) and when I click in "Submit Query" and try to make the upload says "Unknown problem with the upload".

Thumbs up